Always distribute the latest version of interface dll with protected application.

Protected application will detect if you are not using right version of interface dll and display appropriate error message.

Knowledge base